Connexion
Vous n'avez pas encore de compte personnel ? Vous devriez en créer un. Une fois enregistré vous aurez certains avantages, comme pouvoir modifier l'aspect du site, ou poster des commentaires signés...
Support
Activité du Site

Pages vues depuis 06/01/2019 : 14 379 079

  • Nb. de membres 368
  • Nb. d'articles 2 868
  • Nb. de forums 24
  • Nb. de sujets 13
  • Nb. de critiques 0

Top 10  Statistiques

Index du forum »»  Logiciel »» Amigift 2.0: Attention lors de l'installation

Amigift 2.0: Attention lors de l'installation#211

2Contributeur(s)
PapiosaurSergius
1 Modérateur(s)
Papiosaur
Papiosaur Papiosauricon_post
Message posté par Sergius:


Je tiens à signaler que lorsqu'on installe Amigift, ce dernier remplace l'asyncio.library de mossys:libs/ par une version plus ancienne, ce qui empêche le démarrage d'Ambient après un reset.
Pour me dépêtrer de cette situation, j'ai du démarrer sur le CD d'installation de MOS et remettre la bonne library à sa place.


Message édité par : Papiosaur / 10-06-2009 18:52

Papiosaur Papiosauricon_post
Sergius, tu parle de quelle version d'AmiGift ?

Car dans la version 2.0, je n'ai pas vu de script d'installation ni de asynchio.library.

Pourrais-tu nous éclaircir stp ?
Sergius Sergiusicon_post
sur le site d'Amigift, dans la colonne de droite il y a un encadré expliquant que des éléments nécessaires pour faire fonctionner Amigift ne sont pas présents dans l'archive principale.
Ces éléments sont disponibles ici http://sourceforge.net/project/downloading.php?group_id=89295&filename=AMIGIFT-deps.lha

Site d'Amigift http://amigift.sourceforge.net/

Les deux problèmes qui ont été soulevés avec Amigift furent, la nécessité d'avoir OpenURL 7.5 alors qu'une version en 6.3 est intégrée dans Morphos. Le fait d'installer la version 7.5 par dessus la 6.3 posait question.
Il est à noter que l'auteur à été informé de ce conflit de versions et à cette occasion a fait une mise à jour d'Amigift n'exigeant plus que la version 6.3 qui contient toutes les fonctions nécessaires pour Amigift.

Le second problème est généré par l'installer de cette fameuse archive contenant les éléments supplémentaires nécessaires et dont le script d'installation écrase la asynchio.library. L'auteur d'Amigift a aussi été mis au courant de cela et il s'intéroge sur un éventuel bug de l'installer de Morphos car pour remplacer une library, l'installer doit vérifier la version de dite library et ne pas faire de remplacement si la library installée est plus récente, ce qui est le cas.

A mon sens, il serait judicieux de créer un script d'installation prenant en compte le fait qu'il ne faut en aucun cas toucher au contenu de mossys:, mais uniquement sys:

Message édité par : Papiosaur / 10-06-2009 20:29

Papiosaur Papiosauricon_post
Merci beaucoup Sergius pour ces explications.

Je ne connaissait pas cette archive AMIGIFT-deps.lha

En effet, aucun script d'installation ne devrait toucher à MOSSYS:

Je vais voir si il est facile de modifier le script d'installation et de faire ainsi une archive spéciale pour les utilisateurs de MorphOS.

[EDIT] On dirai que le développeur a supprimer l'asyncio.library de l'archive car je ne la trouve plus.

[EDIT2] Je n'ai pas trouvé l'asyncio.library mais elle est bien copiée, zut faut que je retrouve le CD de MOS 2.2 ;-)

Message édité par : Papiosaur / 10-06-2009 21:01